I am not sure where I have gone wrong in my configuration but I am getting the error Reverse DNS does not contain the hostname for my domain sparkdojo.com I had the hosting company set the PTR record to host2.sparkdojo.com and all of the tests I have conducted using dig and host seem to return the correct information. I have waited 24 hours because I read somewhere that the results might be cached or need to propagate but still I am still getting the error. I am hoping someone with more knowledge can determine what is wrong.

UPDATE:

dig -x 162.254.149.186

; <<>> DiG 9.8.3-P1 <<>> -x 162.254.149.186
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21705
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;186.149.254.162.in-addr.arpa.  IN  PTR


;; ANSWER SECTION:
186.149.254.162.in-addr.arpa. 43200 IN  PTR host2.sparkdojo.com.

;; AUTHORITY SECTION:
149.254.162.in-addr.arpa. 34369 IN  NS  rdns1.hivelocity.net.
149.254.162.in-addr.arpa. 34369 IN  NS  rdns2.hivelocity.net.

;; ADDITIONAL SECTION:
rdns1.hivelocity.net.   74146   IN  A   199.193.113.131
rdns2.hivelocity.net.   74146   IN  A   199.193.113.132

;; Query time: 79 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sat May 16 14:33:04 2015
;; MSG SIZE  rcvd: 165

Host Command

host 162.254.149.186
186.149.254.162.in-addr.arpa domain name pointer host2.sparkdojo.com.

MXToolBox Transcript

Connecting to 162.254.149.186

220-host2.sparkdojo.com ESMTP Exim 4.85 #2 Sat, 16 May 2015 14:18:48 -0500 
220-We do not authorize the use of this system to transport unsolicited, 
220 and/or bulk e-mail. [780 ms]
EHLO MXTB-PWS3.mxtoolbox.com
250-host2.sparkdojo.com Hello mxtb-pws3.mxtoolbox.com [64.20.227.133]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP [655 ms]
MAIL FROM:<[email protected]>
250 OK [655 ms]
RCPT TO:<[email protected]>
550-Please turn on SMTP Authentication in your mail client. 
550-mxtb-pws3.mxtoolbox.com [64.20.227.133]:58085 is not permitted to relay
550 through this server without authentication. [889 ms]

MXTB-PWS3v2 3884ms

The error started showing up when I changed the hostname of the server and had the PTR record updated on the host IP. It was showing up as Hivelocity’s default PTR and hostname before so I wanted to make sure that it reflected my domain instead of theirs. There has not been any other changes other than what I listed above.

Leave a Reply

Your email address will not be published. Required fields are marked *