I’d like to solve a question with your kind help, about nslookup on Windows. Please see my CMD commands below(run on WinXP SP2).

C:>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : vchjXPsp3MUI
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter LAN1-hostvn1:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

        Physical Address. . . . . . . . . : 00-0C-29-E0-68-00
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.11.120
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.11.1
        DHCP Server . . . . . . . . . . . : 192.168.11.1
        DNS Servers . . . . . . . . . . . : 172.27.0.12
        Primary WINS Server . . . . . . . : 172.27.0.12
        Lease Obtained. . . . . . . . . . : Wednesday, August 03, 2011 8:58:19 AM
        Lease Expires . . . . . . . . . . : Thursday, August 02, 2012 8:58:19 AM

Ethernet adapter LAN2-bridged:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

        Physical Address. . . . . . . . . : 00-0C-29-E0-68-0A

C:>ipconfig /flushdns

Windows IP Configuration

Successfully flushed the DNS Resolver Cache.

C:>nslookup
*** Can't find server name for address 172.27.0.12: Non-existent domain
*** Default servers are not available
Default Server:  UnKnown
Address:  172.27.0.12

> chj.dev.nls
Server:  UnKnown
Address:  172.27.0.12

Name:    chj.dev.nls
Address:  172.27.0.120

>

You can see that I have assigned a DNS server in my IP configuration, but WHY does nslookup spouts

*** Can't find server name for address 172.27.0.12: Non-existent domain
*** Default servers are not available
Default Server: Unknown

What does it mean by saying “not available” and Unknown”.?

The DNS server(172.27.0.12) is working correctly because it answers query of chj.dev.nls as expected. The DNS server is a Win2003 SP2.

Some detail info:

> set debug
> chj.dev.nls
Server:  UnKnown
Address:  172.27.0.12

------------
Got answer:
    HEADER:
        opcode = QUERY, id = 4, rcode = NOERROR
        header flags:  response, auth. answer, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        chj.dev.nls, type = A, class = IN
    AUTHORITY RECORDS:
    ->  dev.nls
        ttl = 3600 (1 hour)
        primary name server = nlserver.dev.nls
        responsible mail addr = hostmaster.dev.nls
        serial  = 14716
        refresh = 900 (15 mins)
        retry   = 600 (10 mins)
        expire  = 86400 (1 day)
        default TTL = 3600 (1 hour)

------------
------------
Got answer:
    HEADER:
        opcode = QUERY, id = 5, rcode = NOERROR
        header flags:  response, auth. answer, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        chj.dev.nls, type = A, class = IN
    AUTHORITY RECORDS:
    ->  dev.nls
        ttl = 3600 (1 hour)
        primary name server = nlserver.dev.nls
        responsible mail addr = hostmaster.dev.nls
        serial  = 14716
        refresh = 900 (15 mins)
        retry   = 600 (10 mins)
        expire  = 86400 (1 day)
        default TTL = 3600 (1 hour)

------------
Name:    chj.dev.nls

>

Any idea? Thank you.

Leave a Reply

Your email address will not be published. Required fields are marked *